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Abstract
Callose is a β-1,3-glucan polysaccharide that is deposited at discrete sites in the plant cell wall
in response to microbial pathogens, likely contributing to protection against pathogen infec-

tion. Increased callose deposition also occurs in response to the 22-amino acid peptide flg22, a

pathogen-associated molecular pattern (PAMP) derived from bacterial flagellin protein. Here,

we provide protocols for callose staining using aniline blue in cotyledon and leaf tissue of the

model plant Arabidopsis thaliana. Aniline blue stain utilizes a fluorochrome that complexes

with callose for its visualization by microscopy using an ultraviolet (UV) filter. For robust

quantification of callose deposits, we outline an automated image analysis workflow utilizing

the freely available Fiji (Fiji Is Just ImageJ; NIH) software and a Trainable Weka Segmenta-

tion (TWS) plugin. Our methodology for automated analysis of large batches of images can be

easily adapted to quantify callose in other tissues and plant species, as well as to quantify fluo-

rescent structures other than callose.

1 Introduction
Each year, a substantial percentage of crops are lost to pathogenic infection, which

can lead to significant economic loss and reduced food security (Savary et al., 2019).

Understanding the natural defenses of plants can inspire novel approaches to

engineer durable resistance in crop species, contributing to increased agricultural

production. A plant’s first line of defense includes preformed and induced immune

responses, with the latter utilizing the perception of pathogen-associated molecular

patterns (PAMPs) by the plant using pattern recognition receptors (PRRs). PRRs

initiate an array of immune responses that contribute to pattern-triggered immunity

(PTI) to help the host defend itself against non-adpated pathogens (Xin & He, 2013;

Yu, Feng, He, & Shan, 2017). One of the best-established microbial PAMP—host

PRR system to study immune responses in the model plant, Arabidopsis thaliana,
is flg22, the 22-amino acid PAMP derived from flagellin, a bacterial protein that

serves as the building block for the flagella of pathogenic Pseudomonas strains

and is necessary for host infection (Xin & He, 2013). flg22 is recognized by the plant

PRR, FLAGELLIN SENSING 2 (FLS2), to initiate a myriad of early, intermediate

and late defense responses within the host cell (Collins et al., 2020; Yu et al., 2017),

including callose deposition (Leslie, Rogers, & Heese, 2016; Smith et al., 2014),

which is considered a late PAMP response.

Callose is a β-1,3-glucan polymer of high molecular weight that exists in plant

cell walls and is required for normal plant growth and development. Callose is also

deposited in wound sites, papillae, and plasmodesmata during plant defense against

pathogenic microbes (Ellinger & Voigt, 2014; Nishimura et al., 2003). The exact

function of callose in conferring immunity against diverse pathogens is still debated;

but stress-induced callose is deposited in cell walls near the neck zone of plasmodes-

mata to control plasmodesmal permeability and symplastic signaling between
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neighboring plant cells (Cheval & Faulkner, 2018; Wu, Kumar, Iswanto, & Kim,

2018). Callose deposition may also help reinforce weak or compromised cell walls

and form a cell wall matrix for the deposition of antimicrobial compounds to provide

targeted chemical defense at the site of microbial pathogen attack (Luna et al., 2011).

A straightforward method to visualize callose deposition is through aniline blue

staining. The fluorochrome present in commercially available aniline blue stain com-

plexes with β-1,3-glucans to fluoresce at a wavelength of 500–506nm when excited

with UV light (Smith & McCully, 1978). While aniline blue can bind other com-

pounds in the plant cell wall, the fluorochrome shows stronger association with

β-1,3-glucans due to the greater accessibility of the polymer (Hood & Shew,

1996). Once stained with aniline blue, plant tissues can be imaged with fluorescence

microscopy for subsequent quantification of callose deposition.

Here, we present methods for flg22-induced callose in both cotyledons (Fig. 1A)

and leaves of mature Arabidopsis plants (Fig. 1B); callose staining using aniline

blue; and callose imaging using fluorescence microscopy. We also provide a work-

flow for the automated quantification of callose staining across large data sets uti-

lizing the free and open-source software Fiji (Fiji Is Just ImageJ) and the

Trainable Weka Segmentation (TWS) plugin (https://imagej.net/Trainable_Weka_

Segmentation). This Fiji plugin allows the user to train the program to recognize spe-

cific features within an image and then uses machine learning algorithms to classify a

large set of images. Image analysis can be separated into three main steps: 1. crop-

ping of images to remove background and measure area; 2. segmentation of images

to recognize callose deposits; and 3. analysis of particles to quantify results. This

plugin is versatile, in that it can be utilized to quantify a multitude of cellular changes

that includes quantifying flg22-induced endocytosis of fluorescence protein-tagged

FLS2 in endosomal puncta (Leslie & Heese, 2017).

2 Elicitation
In Arabidopsis, the deposition of callose in response to flg22 or other PAMPs is well-

established in cotyledons of 7- to 8-day old seedlings and in mature leaves of 5- to

6-week old plants. Callose is a late immune response (Yu et al., 2017), so elicitation

can be carried out for 16–24h in both seedlings and mature leaves to observe a robust

callose response. However, because a mutation may lead to constitutive activation of

defense responses that are independent of a PAMP, it is critical to include negative

control(s) for proper interpretation of callose staining experiments. Negative controls

consist of treating tissue with a non-functional flg22 peptide derived from Agrobac-
terium tumefaciens, or with dimethyl sulfoxide (DMSO; solvent for flg22-peptide)

(mock) (Korasick et al., 2010). Because flg22-induced callose is dependent on

CALLOSE SYNTHASE 12 (CalS12)/GLUCAN SYNTHASE-LIKE 5 (GSL5), also

referred to as POWDERY MILDEW RESISTANT 4 (PMR4) (Ellinger & Voigt,

2014; Nishimura et al., 2003), loss of function pmr4-1 null mutant plants can serve

as negative controls (Leslie et al., 2016).
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Select seedlings from plates

and carefully transfer to dH2O

Incubate over night in

growth chamber

Replace with D/PAMP (+)

or mock (–) solution

Treat for 24 hr

Replace with 95% ethanol

Replace 95% ethanol

Transfer to 95% ethanol

Take leaf punches

Treat for 24 hr in

growth chamber

Syringe-infiltrate

D/PAMP (+) or

mock (–) solution

Incubate and fix tissue in 95% ethanol,

Incubate and fix tissue in 95% ethanol,

Replace solution with 50% ethanol,

Replace solution with 50% ethanol,

Replace solution with 67 mM K2HPO4,

Replace solution with 67 mM K2HPO4,

Replace solution with 67 mM K2HPO4, Replace solution with 67 mM K2HPO4

Stain with Aniline Blue for 1 hr
Stain with Aniline Blue for 1 hr

WT mt WT mt

WT  mt    WT   mt

incubate for 30–60 min

incubate for 30–60 min

incubate for 30–60 min

incubate for 30–60 min

incubate for 30–60 min

incubate for 30–60 min

and wash for 60 min and wash for 60 min

Mount cotyledons abaxial side up Mount leaf discs abaxial side up

A B

FIG. 1

Flowchart for elicitation, fixation, aniline blue staining and mounting of Arabidopsis tissue.

Flow chart for (A) seedlings and (B) leaf tissue.
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2.1 Elicitation in cotyledons of seedlings
As shown in Figs. 1A and 2, seedlings are elicited by flotation in liquid solution

containing flg22, during which the epidermis of cotyledons and other organs is

exposed directly to flg22. In addition, roots take up flg22 from the solution, resulting

in flg22-induced responses within tissues other than the epidermis. This flotation

method only requires solution changes and is straightforward and easy, but one dis-

advantage is that the amount of flg22 uptake cannot be regulated directly, resulting in

more varied responses between each cotyledon of different seedlings. For seedling

assays, we typically select 12 seedlings per genotype and treatment.

2.1.1 Materials
• 7- to 8-day old Arabidopsis wildtype and mutant seedlings ecotype Col-0 grown

on½MS+1% sucrose plates (see Section 5.1) at 22 °C and 24-h light photoperiod

at 82μmolm2s�1

• Straight tapered flat point forceps (Catalog# 12-000-123, Fisher Scientific)

• 12- or 24-well sterile Falcon™ Polystyrene Microplates (Catalog# 08-772-29 or

08-772-1, respectively; Fisher Scientific)

• Sterile distilled H2O

• Micropore Surgical Paper Tape (Catalog# 19-061655, Fisher Scientific)

• Elicitation solution (see Section 5.2)

• Dimethyl sulfoxide (DMSO; �99.7% purity; Catalog# BP231-100, Fisher

Scientific)

• 95% Ethanol

• Pseudomonas aeruginosa flg22 peptide (GenScript; see Section 5.2)

• Agrobacterium tumefaciens flg22 peptide, if used as a negative control

(GenScript; see Section 5.2)

FIG. 2

Representative images of seedlings during elicitation and fixation procedure. (A) After placing

7-day old seedlings in dH2O overnight to reduce wound responses, seedlings are elicited with

100nM–1μM flg22 or mock solution for 24h. (B) Carefully remove all elicitation solution and

incubate seedlings in 95% ethanol to remove chlorophyll and fix tissue. (C) After multiple

95% ethanol changes, make sure that the last ethanol wash results in a clear solution and

seedlings appear translucent white before proceeding with aniline blue staining.
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2.1.2 Protocol
1. Fill each well of a sterile tissue culture plate with 1mL of sterile dH2O.

Note: Volumes of water or other solutions may need to be adjusted depending

on well size; but volumes must be consistent between all wells and between

different experiments.

Note: Instead of water, wells may be filled with liquid media similar to growth

plate conditions (½MS+1% sucrose, no agar) to prevent nutritional deficiencies

and/or osmotic shock.

2. Gently lift seedlings in a scooping motion by placing the forceps underneath the

cotyledons with one tip of the forceps on either side of the hypocotyl and transfer

to well (Fig. 2A). For 12- or 24-well plates, place three or four seedlings per well,

respectively.

Note: Damage caused by forceps will produce wound-induced callose

unrelated to flg22-elicitation. The latter will also be stained by aniline blue, and

thus may skew results.

Note: To decrease variability between experiments, keep the time of day

when seedlings are picked consistent between experiments.

3. Seal plate with micropore tape. Leave overnight (16h) in the same growth

chamber as they were before (22 °C, 24-h light).

Note: Leaving seedlings in water or liquid½MS overnight will reduce wound

responses and is necessary for subsequent flg22-responses.

Note: In different mutants, effects of light conditions may affect flg22-

induced callose differently, and thus may need to be altered.

4. Prepare elicitation solutions using sterile dH2O (see Section 5.2). Prepare 1mL of

solution per well plus one or two well excess.

i. Positive treatment: Pseudomonas aeruginosa flg22 (active flg22; flg22Paer)

(or other PAMP); final concentration: 100nM–1μM.

ii. Negative control: Agrobacterium tumefaciens flg22 (inactive flg22;

flg22Atum) at the same concentration as the positive treatment OR mock

treatment prepared by adding the same volume of DMSO as used for flg22Paer

to sterile dH2O.

Note: Other bacterial PAMPs such as bacterial elf26, or the plant-derived

damage-associated molecular patterns (DAMP) AtPEP1, allow for comparing

callose deposits in response to diverse D/PAMPs.

Note: Some mutant seedlings may show constitutive activation of defense

responses independent of active D/PAMPs. Therefore, including negative

controls are critical for proper interpretation of PAMP-induced callose

production.

5. Swiftly but carefully remove dH2O from individual wells without damaging

seedling tissue.

Note: Make sure to remove all liquid from individual wells including that

trapped underneath cotyledons by gently tapping the plate. Insufficient dH2O

removal can result in diluting, thus changing the final flg22-concentration
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between wells, which in turn leads to increased variability in responses

observed between wells and/or experiments.

Note: Move quickly to avoid drying out of seedling tissue.

6. To elicit callose deposition, add 1mL elicitation solution to each well and incubate

for 24h in the same growth chamber as they were before (22°C, 24-h light).

Note: Elicitation time may be shortened to 12–16h depending on growth

conditions, flg22-concentration and genotype.

7. Replace elicitation solution with 95% ethanol to fix seedlings and stop responses

(Fig. 2B and C).

2.2 Elicitation in mature leaves
Mature leaves are syringe-infiltrated with elicitation solution (Figs. 1B and 3), which

has the advantage that the solution permeates through all tissue for a potentially

stronger flg22 response. Infiltrating different leaves of the same plant with both

FIG. 3

Representative images for flg22-elicitation, tissue collection and fixation of leaf tissue. (A) In

6-week old plants, immediately prior to leaf infiltration, poke 3–4 holes (arrows) in selected

leaves to enable (B) syringe-infiltration with 10nM–1μM flg22 (elicitor solution) or mock

treatment. (C) Infiltrate three leaves (stars) of similar developmental stage within each rosette.

(D) After 24-h elicitation, collect leaf tissue by punching leaf disks on either side ofmidrib from

infiltrated leaves. (E) Transfer leaf disks immediately into 95% ethanol to clear and fix tissue.

Change 95% ethanol solution multiple times. (F) For the last wash in 95% ethanol, the

solution should remain clear, and all leaf disks should appear translucent white before

proceeding to aniline blue staining.
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active and inactive elicitation (or mock) solutions should be avoided because it can

skew results due to cross-contamination from eliciting solution that may spray or drip

onto leaves infiltrated with negative control solution. Furthermore, infiltration of

active flg22 in one leaf can induce systemic responses in another leaf over time, po-

tentially contributing to inaccurate results. For mature leaves, we typically infiltrate

three fully expanded leaves of at least 3–4 different plants (for a total of 18–24 leaf

disks) for each genotype and treatment.

2.2.1 Materials
• 5- to 6-week old mature Arabidopsis plants grown on soil at 22 °C, 8-h light/16-h

dark cycle photoperiod at 82μmolm2s�1.

• Sterile dH2O

• Elicitation solution (See Section 5.2)

• DMSO (�99.7% purity; Catalog# BP231-100, Fisher Scientific)

• Gel loading tips or sterile toothpicks

• 1mL Syringe without needle (sterile) (Catalog# 14-817-25, Fisher Scientific)

• Kimwipes or equivalent lab wipes

• 12-Well sterile Falcon™ Polystyrene Microplates (Catalog# 08-772-29, Fisher

Scientific)

• Straight tapered flat point forceps (Catalog# 12-000-123, Fisher Scientific)

• 95% Ethanol

• #2 or 0.2cm2 cork borer for leaf tissue punch (Catalog# 07-865-10B, Fisher

Scientific)

2.2.2 Protocol
1. Before preparing elicitation and negative control solutions for infiltration, check

that the plant growth chamber is free of pests. Avoid plants that show any

symptoms of prior pathogen infection, and any leaves with previous damage,

chlorosis or visible cell death that may have caused callose deposition prior to or

independent of D/PAMP elicitation, thus skewing results.

Note: To ease with infiltration, we water plants the day before elicitation.

Check, sort and label all plants with information on genotype, concentration

and type of elicitation solution prior to preparing the elicitation solution.

Exclude plants that have produced inflorescence stems.

2. Prepare 1mL elicitation solution per plant using sterile dH2O. If necessary,

adjust this volume for future experiments.

i. Positive treatment: 10nM–1μM flg22Paer (or other active D/PAMP)

ii. Negative control: flg22Atum at the same concentration as positive treatment

OR mock treatment with DMSO.

Note: Determine the optimal flg22 concentration empirically, because

different mutants may respond differently to distinct PAMP concentrations.

Use serial dilution to prepare different flg22 concentrations to assess

whether a mutant has altered callose deposition compared to wild type.

3. Using gel loading tips or sterile toothpicks, carefully punch four small holes

in the leaf; two at the apex and two at the base of the leaf blade (Fig. 3A).

Avoid ripping or severely damaging leaf tissue.
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4. Fill syringe with elicitation solution. Supporting the bottom side of the leaf

with a gloved finger, place opening of syringe on one hole in leaf tissue

near apex and slowly inject solution (Fig. 3B). Do not press syringe onto

tissue too strongly as it will damage surrounding tissue, resulting in callose

deposition unrelated to elicitation. Press only enough to create a seal for

injecting solution.

5. Repeat infiltration at the other three holes at apex and base. Check that

the infiltration solution has spread through the entire blade and entered

the petiole. Infiltrated leaf tissue appears darker in color and more

translucent than non-infiltrated areas (Fig. 3C). If applicable, mark

non-infiltrated areas with a black sharpie and avoid those sections for

callose analyses. Alternatively, turn leaf over and very gently place syringe

near the uninfiltrated area and inject solution through stomata on the

abaxial side.

6. Gently remove excess solution with a Kimwipe without damaging tissue.

7. Repeat infiltration into additional leaves at comparable developmental stages

within the same plant (Figs. 1B and 3C).

8. Infiltrate set of plants with active flg22Paer first. Change all tips, syringes, and

gloves and wipe down surface before starting from step 3 to infiltrate

another set of plants with mock treatment.

9. Cover plant trays with a clear dome lid for 24h under same growth

conditions as before (22 °C, 8-h light).

10. Prior to collecting leaf samples, label 12-well plates with genotype and

treatment information using an alcohol-resistant marking pen. Fill each well

with 1mL of 95% ethanol.

11. After 24-h elicitation, collect two leaf disk punches from each infiltrated

leaf with one punch from each side of the midrib (Fig. 3D).

Note: Number of leaf punches may be adjusted depending on leaf size

between wild-type and mutant plants. If within an experiment, leaf size across

all genotypes are large and of similar size, four disks (two on each side of

midrib) may be taken to increase sample number (Fig. 1B). If leaves of mutant

plants are too small to punch an entire leaf disk on either side of the midrib,

then punch disk(s) across midrib for all plants of all genotypes and treatments to

stay consistent within an experiment.

Note: Make sure to sharpen leaf puncher periodically to prevent extensive

tissue damage.

12. Transfer leaf punches using forceps to wells containing 95% ethanol to stop

defense/wounding reactions and start fixing leaf tissue.

Note: Place all leaf punches from same plant into the same well (i.e., six leaf

disks per well) (Fig. 3E). This will address reproducibility within an

experiment, in that it allows keeping track of whether different plants of the

same genotype and treatment behave similarly.

Note: If leaf disks overlap, use plate with larger well size or add fewer leaf

disks per well.
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3 Aniline blue staining, tissue mounting and microscopy
Aniline blue is an effective stain for callose in plant tissue and is routinely used to

detect flg22-induced callose in both cotyledons and leaf tissue. One disadvantage is

that aniline blue is not specific for callose but may complex with other plant cell wall

components (Smith & McCully, 1978).

3.1 Materials
• 95% Ethanol

• 50% Ethanol

• Sterile dH2O

• 10� K2HPO4 stock solution (670mM Potassium phosphate dibasic trihydrate

(K2HPO4), pH 12; Catalog# P5504, Sigma-Aldrich)

• 67mM K2HPO4 working solution (pH 12; made by 10� K2HPO4 stock solution

10� in sterile dH2O)

• Aniline Blue (Catalog# 415049-50G, Sigma-Aldrich)

• Glycerol (Catalog# BP229-1, Fisher Scientific)

• Parafilm (Catalog# PM992, Bemis™)

• Aluminum Foil

• 1.7mL microcentrifuge tubes (Catalog# 07-200-534, Fisher Scientific)

• Mounting media (70% glycerol in 67mM K2HPO4, pH 12)

• Premium Superfrost Microscope Slides (Catalog# 12-544-7, Fisher Scientific)

• Cover Slips (50�24mm; Catalog# 12-545-88, Fisher Scientific)

• Sally Hansen Clear Nail Polish

• Slide box (Catalog# 03-446, Fisher Scientific)

• Leica M205 FA stereoscope with UV fluorescence filter (or equivalent)

3.2 Protocol
1. Clear and fix tissue in 1mL 95% ethanol on rocker at room temperature (RT)

(Figs. 2B and 3E). Change 95% ethanol multiple times and incubate for

30–60min each time to ensure complete removal of chlorophyll.

Note: Residual chlorophyll appears as a milky substance during imaging

using a UV filter and interferes with callose detection and quantification.

2. Once tissue is translucent white (Figs. 2C and 3F), wrap plate with parafilm and

leave on rocker at 4 °C until ready for staining. Samples can be kept in 95%

ethanol for up to a week at 4 °C.
Note: Make sure to periodically change or replenish 95% ethanol to avoid

tissue drying.
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3. Rinse tissue with 1mL 50% ethanol. Discard solution and incubate tissue in 1mL

50% ethanol for 30–60min on rocker at RT.

Note: For this and subsequent steps, change liquid in one well at a time to

prevent drying out of tissue.

4. Rinse tissue with 1mL 67mM K2HPO4 (pH 12). Discard solution and rehydrate

tissue in 1mL 67mM K2HPO4 (pH 12) for 30–60min on rocker at RT.

Note: Prepare 10� K2HPO4 (pH 12) stock solution using KOH pellets to

adjust pH. Filter-sterilize 10� and 1� K2HPO4 solutions through a 0.2μm filter

to remove any dust particles as they may interfere with imaging.

Note: For efficacy of aniline blue to stain callose deposits and to retain its

buffering capacity, K2HPO4 must be at a basic pH of 12 and at a final

concentration of 67mM, respectively.

5. Prepare 0.01% (w/v) aniline blue in 67mM K2HPO4 (pH 12) (aniline blue

staining solution) as described in Section 5.3. To stain tissue, exchange 67mM

K2HPO4 (pH 12) solution with 1mL aniline blue staining solution and incubate

for 60min on rocker at RT. Because aniline blue may be light sensitive, wrap

plate in aluminum foil.

Note: Prepare 1–2mL excess of aniline blue staining solution. For

consistency, all samples within an experiment must be stained with the same

preparation of 0.01% aniline blue solution.

6. Rinse samples in 1mL 67mM K2HPO4 (pH 12). Discard solution and wash

stained tissue in 1mL 67mM K2HPO4 (pH 12) for 60min on rocker at RT.

Note: Plant tissue is easiest tomount immediately after staining. However, plates

can be sealed with parafilm and left overnight on a rocker at 4°C. Tissue becomes

less rigid over time in 67mM K2HPO4 (pH 12), making it more difficult to mount.

7. Prior to mounting tissue onto microscope slides, prepare mounting solution.

Note: For 10mL mounting solution, use 7mL 100% glycerol, 1mL 10�
K2HPO4 (pH 12) stock solution and 2mL dH2O and store at 4°C for up to 1 month.

8. Mount seedlings on Premium Superfrost Microscope Slides by spreading out

100–150μL of mounting media onto labeled slide. Gently place tissue into

mounting media on slide with abaxial side facing up, spread out and flat. Use one

slide for tissues from one well (Fig. 1). Place coverslip in one smooth motion

beginning at one edge of slide to prevent trapping of air bubbles. Seal edges of

coverslip with nail polish. Store slides in slide box at 4 °C.
Note: Placing a black background under slides makes it easier to visualize

cleared translucent tissue to arrange on slide.

Note: Use a fine pipette tip, potentially under a dissecting microscope, to

ensure that cotyledons or leaf disks are not folded over or overlap with other

tissues such as roots.

Note: For consistent data collection, it is critical that all cotyledon or leaf

samples are placed on slides with the abaxial (lower surface) facing up. This is

because adaxial (upper) and abaxial (lower) surfaces are developmentally

distinct, and thus respond differently to flg22-elicitation. In addition,
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developmentally deposited callose accumulates at the bases of trichomes, which

are more abundant on adaxial (upper) epidermis of cotyledons or leaves,

interfering with quantification of stress-induced callose.

Note: Slide boxes may be wrapped in plastic wrap to reduce condensation

on slides.

9. For callose detection, examinemounted tissue using amicroscope equippedwith a

mercury lamp and a “DAPI” filter set or equivalent filter set for detecting aniline

blue complexed with β-1,3-glucan (excitation and emission maxima 390nm and

500–506nm, respectively) (Smith & McCully, 1978). We use a Leica M205 FA

stereoscope with a mercury lamp and UV filter (excitation filter 390nm; longpass

emission filter 420nm). Set microscope magnification to fit one entire cotyledon

of the largest genotype (Fig. 4A) or one leaf disk in microscope field of view. Use

grayscale during image acquisition and exposure that creates the best contrast

between callose deposits (bright white) and the leaf tissue (gray) (Fig. 4A and B).

FIG. 4

Representative images of callose deposition and subsequent quantification process using Fiji.

(A) Wild-type Col-0 cotyledon after 24h treatment without (� flg22, DMSO) or with flg22

(+ 1μM flg22). Scale bar, 1mm. (B) Close-up images of Col-0 and pmr4-1 cotyledons after

24h treatment without (� flg22, DMSO) or with flg22 (+ 1μM flg22). Scale bar, 0.5mm.

(C) Automated large-scale image quantification of callose deposits/area (callose deposits/

mm2) identified differences in callose deposition between different genotypes (Col-0, pmr4-1)

and different treatments (�/+ 1μM flg22 for 24h). Values are mean�SEM with n¼22–24

cotyledons per treatment. Different letters indicate statistically significant differences as

determined by one-way Anova with Tukey multiple comparisons test (P<0.05).

(D) Representative step-by-step images generated during in Fiji quantification process for

cropping, segmentation and particle analysis with a final image showing the overlay of

detected callose deposits onto cropped image.
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Note: Acquire all images within an experiment at the same magnification and

exposure time. Try to take all images during the same microscope session to

reduce image variability, which can affect subsequent quantification.

4 Quantification of callose deposits
Quantification of callose deposits across large sets of image data allows for compar-

isons of responses to flg22 and mock treatments between wild-type and mutant

genotypes such as Col-0 and pmr4-1, respectively (Fig. 4B and C), with the ability

to discern subtle but significant differences between different genotypes (Leslie

et al., 2016). Our preferred program for callose quantification is Fiji, a powerful tool

for scientists to conduct advanced, large-scale image analysis (Schindelin et al.,

2012). Here, we employ Fiji to create classifiers with the help of the existing Train-

able Weka Segmentation (TWS) plugin. In the initial step, a single callose image is

utilized to establish a Fiji-derived workflow that allows the user to process large

batches of callose datasets. This processing pipeline is easily adaptable for each

experiment due to the creation of a segmentation classifier that can discern callose

deposits from the other features in an image. Each image is cropped and measured

individually, but this process can be made more efficient by designing a Fiji macro

that condenses multiple steps into one and analyzes particles for a batch set of im-

ages. As part of Fiji, the TWS plugin saves time and produces less biased analysis of

data due to the development of a classifier that can be applied to a whole set of im-

ages. In Fig. 4D, we provide a quantification workflow that utilizes Fiji for image

cropping/measuring, segmentation, and particle analysis. Fig. 5 highlights specific

tools in Fiji and the TWS plugin relevant to callose quantification across large

batches of images.

4.1 Materials
• Computer (preferably with touch screen capabilities)

• Fiji (https://imagej.net/Fiji) including the TWS plugin (https://imagej.net/Train

able_Segmentation)

• Microsoft Office Excel (any version after MSOffice Excel 95)

• GraphPad Prism 8 or other graphing program

• MiniTab or other statistical analysis program

4.2 Protocol
1. Launch Fiji program and open a single image.

Note: If Fiji shows a dialog box requesting to update Fiji upon opening this

program, click “never”; otherwise the subsequent protocol may not work

properly and needs to be adjusted.

2. Setting Measurements: In Fiji, go to Analyze➔ Set Measurements (Fig. 5A,

blue box). Check the boxes for “Display Label” and “Area.”
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FIG. 5

Images of Fiji program relevant for quantification process. (A) Ribbon of Fiji when using

Windows operating system to highlight specific control tabs: Edit (yellow), Image (pink),

Process (purple), Analyze (blue), Plugins (green); and tools for area selection: Oval (black),

Free Hand (red) and Line Selection (gray) (B). Example of dialog box with a defined “clear

measure resize” macro created using the macro recorder. (C) Representative image of the

TWS Fiji plugin to select callose puncta with Oval selection tool to add to class 1 (red box;

included features). Excluded features or background are selected using Line selection tool

and added to class 2 (green box; excluded features). (D) Example of a dialog box with the

“particle analysis” macro that was created using the macro recorder.
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3. Setting scale: Open the corresponding data file that contains all parameters used

during image acquisition. If applicable, convert meters per pixel to millimeters

(mm) per pixel. In Fiji, go to Analyze➔ Set Scale. Enter mm per pixel value as

“Known Distance” and set “Distance in pixels” and “Pixel Aspect Ratio” to 1.

Set “Unit of Length” to mm. Record “Scale” value at bottom to refer to later.

Check the box for Global, which will apply this scale to subsequent images.

Open a new image, and when dialog box pops up, uncheck “Disable Global

Calibration” and check “Do Not Show This Message Again.” Check scale of

new image to make sure correct scale was applied.

Note: If you close the Fiji app at any time during quantification, you will

need to set the scale again.

4. Creating “Clear Measure Resize” Macro (Fig. 5B): Use Freehand Selections
Tool on Ribbon (Fig. 5A, red box) to trace outline of plant tissue, excluding

regions where tissue is folded, overlapping, or torn. Open

Plugins ➔ Macros➔ Record (Fig. 5A, green box). This will record further

actions made in Fiji. Go to Edit ➔ Clear Outside (Fig. 5A, yellow box). This

will exclude everything outside of selection. Go to Analyze➔ Measure to

measure area of selection displayed in results window. Go to

Image ➔ Adjust➔ Size (Fig. 5A, pink box). If raw image is 1600�1200 pixels

wide, we change “Width” to 800 and check boxes for “Constrain Aspect Ratio”

and “Average when Downsizing” to decrease image processing time. Change

Interpolation to “Bilinear.” Click OK. Click Create in upper right corner of

Recorder window. In Macro Script Window that pops up, go to File➔ Save As
and name macro “Clear Measure Resize.” This macro can be used for future

experiments and does not need to be adjusted every time.

5. Cropping: Create a copy of the original folder with all the images from

experiment and rename it “cropped version.” Open the first image file from

“cropped version” folder. In Fiji, go to Plugins ➔ Macros ➔ About Startup
Macros. Within Macros Script window, go to File➔ Open and choose “Clear

Measure Resize” macro. Choose Freehand Selections Tool on Ribbon. Trace

outline of plant tissue, excluding regions where tissue is folded, overlapping, or

torn. Press “Run” on Macro Script window. Save and overwrite image file.

Repeat cropping protocol for each image in “cropped version” folder. Copy all

labels and area measurements from Results window into an Excel spreadsheet

titled Callose Quantification.

Note: Crop images in alphabetical order by name because later steps will

batch process the folder in that same order. Alternatively, arrange them in

alphabetical order after pasting in Excel.

6. Segmentation: Create a new folder titled “Segmentation Results.” Open a single

cropped version .tif file from previous step that is a good representative of

callose deposition. Reset the scale by going to Analyze ➔ Set Scale. If width of
original raw image has been changed from 1600 to 800 pixels (see step 4

Section 4.2), divide “Distance in Pixels” by 2 and replace value. Check box for

Global to apply new scale to all images. To start creating a classifier, go to
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Plugins ➔ Segmentation ➔ Trainable Weka Segmentation. For callose
deposits, use Oval tool (Fig. 5A, black box) to highlight one punctum and then

click “add to class 1” on right side of window (Fig. 5C, red box). Repeat for a

few differently sized callose deposits. For plant tissue, use Line tool (Fig. 5A,
gray box) to highlight a feature without callose and click “add to class 2”

(Fig. 5C, green box). It is best if selected toolmatches relative shape of feature,

in that the Oval tool is best for circular puncta such as callose deposits, and

the Line tool is best for vasculature. Repeat for a few different features such as

vasculature or edges of tissue. After sorting a small number of features into

classes, click “Train Classifier.” Refine classifier by repeating the sorting of

features and retraining the classifier until almost all callose deposits are

recognized with minimal other features being recognized. Click “Save

Classifier” if you want to be able to use this classifier again. Click “Apply

Classifier.” Select all cropped images from previous step and click Open. When

asked “Do youwant the results to be stored on the disk instead of opening them in

Fiji?” select yes and select “Segmentation Results” folder as the save location.

When asked “Create Probability maps instead of segmentation?” select no. Wait

for segmentation analysis to finish processing all selected images.

7. Creating “Callose Analyze Particles” Macro (Fig. 5D): Open a single

segmentation result .tif file from previous step. Open

Plugins ➔ Macros ➔ Record. This will record further selections made in Fiji.

Go to Image ➔ Type and select “8-bit.” If image is not already binary, go to

Process➔ Binary ➔ Make Binary (Fig. 5A purple box). Go to

Analyze➔ Analyze Particles. For “Size (mm2)” box, input range of Area of

callose deposits. Change “Circularity” to 0.25–1. Change “Show” to

“Outlines.” Check the box for “Summarize” only. Click Okay. Create and Save

macro as stated in step 4 and title this macro as “Callose Analyze Particles.”

Note: You can find the Area of callose deposits by using Freehand Selection
Tool and outlining callose deposit and going to Analyze ➔ Measure. Measure

area of largest and smallest callose deposit to create range. The size range of

0.000005–0.005mm2 generally works for the experiments conducted in our lab.

8. Analyze Particles: Create a new folder titled “Analyze Particles Results.” Open

a single segmentation result .tif file from step 6. Check scale so that it is the

same value as segmentation step and apply Global. Go to

Process➔ Batch ➔ Macro. Set the input folder as “Segmentation Results” and

set the output folder as “Analyze Particles Results.” Click “Open” at the bottom

left and select the macro “Callose Analyze Particles.” Click “Process.” Copy the

values in Results window and paste into Excel file next to previous Area data.

9. Calculations: To calculate callose deposits/area (callose deposits/mm2) in the

Excel file, take the particle count (found in step 8) values divided by the

total area of the leaf tissue (found in step 5).

10. Graphing: Use Column Graph in GraphPad Prism 8 or any other graphing

program to graph callose deposits/area (callose deposits/mm2) on y-axis and
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genotypes and treatments on x-axis (Fig. 4C). Use the online tool GraphPad

Outlier Calculator (https://www.graphpad.com/quickcalcs/Grubbs1.cfm) to

identify and if necessary, exclude outliers within datasets.

11. Statistical Analysis: For experiments with multiple genotypes and treatments,

as seen here, use One-way Analysis of Variance (ANOVA) statistical

analysis with Tukey multiple comparisons test (Fig. 4C). We use MiniTab for

our data analysis, but other statistical tools (e.g., R, PAST4) can be used.

5 Precursor techniques
5.1 Preparing 1⁄2 MS+1% sucrose plates
For a final volume of 700mL, add 1.51g Murashige and Skoog (MS) Basal Salt

Mixture (Catalog# M5524-50L, Sigma-Aldrich) to 530mL dH2O. When completely

dissolved, adjust pH to 5.7 using KOH. Bring volume to 630mL and transfer to 1L

bottle with stir bar. Add 4.2g BD Difco™ Agar Technical Solidifying Agent

(Catalog# DF0812-17-9, Fischer Scientific) and mix gently on stir plate. After ster-

ilizing in an autoclave for 30min at 103kPa, 121 °C, let medium cool down to about

60 °C on stir plate. From now on, work under sterile conditions in laminar flow hood.

To the solution, add 70mL of filter-sterilized 10% sucrose (w/v) for a final concen-

tration of 1% sucrose (w/v). Close bottle and stir gently on stir plate. Pour�32mL of

solution into each of about 20 100�100mm square polystyrene petri dishes. Let

plates dry in laminar hood for 30min or until solidified and cooled down. Store plates

wrapped in plastic bags at 4 °C for up to 1 month.

5.2 Preparing elicitation solution
D/PAMPs peptides including active flg22Paer (QRLSTGSRINSAKDDAAGLQIA)

and inactive flg22Atum (ARVSSGLRVGDASDNAAYWSIA) are made by Genscript

(Piscataway, NJ, USA) at a guaranteed purity of �90%. To increase consistency

between experiments utilizing different peptide batches, we prepare stock solutions,

for which lyophilized flg22 peptide is dissolved in DMSO to a concentration of

10mM, adjusted to 100% purity. Because of a potential risk of contamination, it

is critical to test peptides for purity and cellular responses when preparing peptide

stocks (Mueller et al., 2012). All peptide stocks are prepared using filter tips and

stored in low-binding tubes as 10–30μL aliquots at �20 °C. We make single-use

small aliquots to avoid multiple freeze-thaw cycle that may cause peptide degrada-

tion. For a 100nM flg22 elicitation solution, we add 10μL of 100μM flg22 (1000�
stock solution) to 10mL of dH2O (RT) and mix the solution gently. We use serial

dilution to prepare different flg22-concentrations to test for dose-dependent callose

deposition.
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5.3 Preparing aniline blue staining solution
Prepare a 1% aniline blue (w/v) stock solution fresh for each experiment. Dissolve

dye at 10mg/1mL in 67mM K2HPO4 (pH 12) in a 1.7mL microcentrifuge tube by

vortexing. Before subsequent dilutions, centrifuge the resuspended dye for 2min at

17,000 �g to remove any undissolved dye that will appear as bright dots in micros-

copy and interfere with image quantification. Dilute 1% stock solution to a final

concentration of 0.01% aniline blue (w/v). For example, for a 24-well plate, we make

25mL solution (for 24+1 extra well) consisting of 250μL of 1% aniline blue (w/v)

+24.75mL of 67mMK2HPO4 (pH 12). Prepare aniline blue solution in darkness OR

wrap tubes in aluminum foil because aniline blue may be light sensitive.

6 Conclusion
In this chapter, we provide protocols for aniline blue staining of the cell wall poly-

saccharide, callose, and subsequent large-scale automated image quantification

using Fiji. This quantification platform has the advantage of being an open-source

and freely available program. Here, we focus on quantifying flg22-induced callose

deposits in Arabidopsis cotyledons and mature leaves, but this automated image

quantification workflow can be easily adapted to quantify other plant cellular fea-

tures such as altered subcellular localization of fluorescently-tagged proteins in plant

organelles or assessing cell death in diverse tissues and organisms.
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